Ocena wątku:
  • 1 głosów - średnia: 5
  • 1
  • 2
  • 3
  • 4
  • 5
Inne [GS] Think globally, act locally
#41
Mi komenda ls pokazuje tylko pliki zapisanych gier, więc to chyba nie o to chodzi.
Próbowałeś w te pliki scr włożyć instrukcje echo "costam"?
A w ogóle sprawdź, czy nie mają rozszerzenia *.scr.example - bo tu może być haczyk.
#42
Tak mam wpisane w skrypcie echo "TEST" ale komunikatu tego nie widzę przy starcie serwera. Plik na pewno też ma poprawną nazwę bo pisałem, że pod linuxem komendą ls -al widzę go w katalogu scripts.
PS
Udało mi się w końcu stworzyć plik logu o nazwie openttd2.log (poleceniem scripts openttd2.log w pliku on_dedicated.scr) tylko że ... nic się tam nie loguje/zapisuje. PLik powstał bezpośrednio w katalogu /root . Może trzeba przestawić poziom logowania opcją debug_level ???
#43
Dziwne.
A spróbuj z konsoli:
exec scripts/on_dedicated.scr
U mnie się wykonuje.

EDIT: to działają już te skrypty?
Może spróbuj uruchomić openttd z komendą -f
A jak nie pomoże, to debug_level desync=1 i wtedy w autosave jest plik z komunikatami.
#44
Jeszcze jeden pomysł: po prostu przyślij mi cfg dokładnie taki jak na serwerze, pogram sobie i zobaczę o co chodzi.
#45
(05-10-2018, 16:26)McZapkie napisał(a): Jeszcze jeden pomysł: po prostu przyślij mi cfg dokładnie taki jak na serwerze, pogram sobie i zobaczę o co chodzi.

Nie sądzę że grając samemu uda ci się zasymulować te wyskoki/zwiechy skryptu . Założę się, że to zależy co tam gracze nakombinują .... od jakichś specyficznych zdarzeń które trudno będzie wychwycić grając samemu .... Proszę popraw te wagony najpierw w wąskotorówkach bo to jest teraz najbardziej wkurzające ... i doskwierające ...
#46
No właśnie znów nam się wysypał skrypt ... po 11 latach gry ...w poprzedniej było dobrze przez całą grę  .... w przedostatniej wypadł też po 15 latach gry ... Na serwerze jest teraz 6 graczy i 10 założonych firm ... to       chyba trzeba szukać haczyka w logach co się dzieje .... tylko jak to teraz zalogować ... :/
#47
Tocznet, u mnie się nic nie wysypywało, więc być może jest to kwestia jakiś ustawień newgrf (może u mnie był inny przemysł i dlatego się nie sypało) - więc prześlij proszę openttd.cfg swojego serwera, to sprawdzę u siebie.
Co do 600mm, to będą nowe wagony na 40 km/h.
#48
(14-10-2018, 14:38)McZapkie napisał(a): Tocznet, u mnie się nic nie wysypywało, więc być może jest to kwestia jakiś ustawień newgrf (może u mnie był inny przemysł i dlatego się nie sypało) - więc prześlij proszę openttd.cfg swojego serwera, to sprawdzę u siebie.
Co do 600mm, to będą nowe wagony na 40 km/h.

Jak tam testy mojego openttd.cfg ? Są jakieś powtarzalne rezultaty ?


Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości