Ocena wątku:
  • 0 głosów - średnia: 0
  • 1
  • 2
  • 3
  • 4
  • 5
Brak obrazków na forum - powrót do ery internetu łupanego?
#1
Trochę łyso się zrobiło bez nich na stronie.Sad Naprawdę aż tyle transferu one zżerały? Bo jeśli chodzi o szybkość otwierania stron, ich usunięcie niczego nie zmieniło, zwłaszcza po dodaniu SSL'a. Te miniaturki w załącznikach nie zawsze się sprawdzają. Chciałem dokończyć poradnik dotyczący semaforów, ale bez obrazków, ciężko jest to dobrze opisać, a takie przełączanie między oknami na zasadzie: albo widzisz tekst, albo obrazek nie ułatwiają zrozumienia tematu. No i to ograniczenie 12 obrazków w jednym poście, też niczego nie ułatwia. Kurde, niby internet mamy coraz szybszy, komputery również, a tu taka zmiana na gorsze.Sad Jak nie chcecie wracać do dużych obrazków z uploada to może chociaż powiększcie te miniaturki z załączników (np. do 500x500) i usuńcie to ograniczenie 12 sztuk na post - i tak nikt tyle nie daje, a czasami, wyjątkowo zdarza się taka potrzeba. No i coś z tymi suchymi linkami przydałoby się zrobić, aby tak nie straszyły.
#2
Wystarczy, że obrazki będą miały https. Transfer i samo forum nie ma tu nic do rzeczy - to przeglądarki blokują ich wyświetlanie.
#3
(22-01-2018, 01:56)pAter napisał(a): Wystarczy, że obrazki będą miały https. Transfer i samo forum nie ma tu nic do rzeczy - to przeglądarki blokują ich wyświetlanie.

Dziwne, że blokują tylko na tej stronie. Na innych stronach nie spotkałem się z tego typu problemami. Czyli co należy zrobić aby widzieć wszystkie wrzucone na stronie obrazki?
#4
(22-01-2018, 12:52)Walter Novotny napisał(a):
(22-01-2018, 01:56)pAter napisał(a): Wystarczy, że obrazki będą miały https. Transfer i samo forum nie ma tu nic do rzeczy - to przeglądarki blokują ich wyświetlanie.

Dziwne, że blokują tylko na tej stronie. Na innych stronach nie spotkałem się z tego typu problemami. Czyli co należy zrobić aby widzieć wszystkie wrzucone na stronie obrazki?

Nie tylko na tej stronie - od ok. roku przeglądarki wymuszają używanie SSL i każda treść bez tego oznaczana jest jako "niebezpieczna", bo np. osoby w twojej sieci mogą z łatwością sprawdzić na jakie strony wchodzisz, co wpisujesz w formularze i nawet odczytać twoje hasło logowania. Jeśli strona główna ma SSL, a jakiś element (typu właśnie obrazek) go nie ma, to jest on blokowany. Ma to swoje uzasadnienie pod kątem bezpieczeństwa, bo na podstawie takiego niewinnego obrazka można by było daną osobę wyśledzić.

A widzisz to tylko tutaj, bo przejście z http na https (które niedawno zrobił Rysh) jest dosyć rzadkim zjawiskiem.

Rozwiązanie jest takie, że musisz te swoje obrazki umieścić na serwerze, który też ma SSL, czyli adres zaczyna się od "https://" i podmienić ich linki (np. w swojej sygnaturze). W przypadku mojego tematu z mapą Polski wystarczyło dopisać do linków "s", bo imgur obsługuje https, ale nie wszędzie tak jest - po prostu, obrazek nie zadziała. Można też obrazki umieścić bezpośrednio na forum jako załączniki.

Na upartego Rysh mógłby masowo podmienić linki w bazie danych... Wink Byłoby to dosyć pomocne, bo zmiana tysięcy linków ręcznie jest trochę uciążliwa Wink Wydaje mi się, że to powinno zadziałać (nie znam nazw tabeli z postami, ani nazwy kolumny z treścią posta; oczywiście domyślam się, że masz tu MySQL):

Kod:
UPDATE tabela_posty SET kolumna_tresc_posta = REPLACE(kolumna_tresc_posta, '[img=http://', '[img=https://')

Oczywiście nie zapomnij o kopii zapasowej przed wykonaniem zapytania Big Grin

No i jeśli dany obrazek nie zadziała z https to w sumie niewielka strata, bo i tak się teraz nie wyświetla, więc warto to zrobić w ten sposób. Nie jestem też pewny, czy wielkość liter ma znaczenie, więc możesz dla pewności wykonać też zapytanie z '[IMG=http://'.

PS. Jasne też jest, że obrazki z http://upload.mouse.one.pl/ się nie wyświetlą nawet po zmianie linków... Wink
#5
(22-01-2018, 14:04)pAter napisał(a): PS. Jasne też jest, że obrazki z http://upload.mouse.one.pl/ się nie wyświetlą nawet po zmianie linków... Wink

Gdzie właśnie aby wszystko było ok to obrazki na to forum zawsze tam wrzucam...
#6
Został zainstalowany moduł który wymusza aby obrazki i inny content był pobierany z https.


Skocz do:


Użytkownicy przeglądający ten wątek: 1 gości